Cấu hình Router, Switch

Tác giả CCNACCNP, T.M.Hai 31, 2018, 01:31:04 CHIỀU

« Chủ đề trước - Chủ đề tiếp »

0 Thành viên và 1 Khách đang xem chủ đề.

Cấu hình Router, Switch

I. Routing - Định tuyến.

RIP v2

Mã nguồn [Chọn]
r(config)#router rip
r(config-router)#ver 2
r(config-router)#net ip-add (major network)
r(config-router)#no auto-summary
OSPF

Chú ý: Tất cả những Router có cùng Area phải cấu hình giống nhau tất cả các thông số thì khu vực đó mới hoạt động đúng chức năng được.

1. Cấu hình cơ bản.

Mã nguồn [Chọn]
Router(config)#router ospf process ID (difference)
Router(config-router)#network ip-add Wildcard-mask area-ID

2. Cấu hình priority ở các interface để bầu DR và BDR.

Priority càng lớn thì khả năng được bầu làm DR càng cao, ngược với bầu Root brige của Switch, càng nhỏ thì lại càng được bầu.

Mã nguồn [Chọn]
Router(config)#interface fastethernet 0/0
Router(config-int)#ip ospf priority 55

Sau khi cấu hình xong priority có thể kiểm tra bằng lệnh.

Mã nguồn [Chọn]
Router# show ip ospf interface f0/0
3. Chỉnh sửa lại OSPF cost metric trong mỗi interface.

Cost càng nhỏ thì tuyến đó càng được coi là Best Path.

Mã nguồn [Chọn]
Router(config-int)#ip ospf cost 1
4. Các lệnh show dùng để kiểm tra cấu hình OSPF.

Mã nguồn [Chọn]
show ip protocol
show ip route
show ip ospf
show ip ospf interface
show ip ospf database
show ip ospf neighbor detail
clear ip route *
debug ip ospf events
debug ip ospf adj
II. EIGRP.

1. Cấu hình cơ bản.

Mã nguồn [Chọn]
Router(config)#router eigrp As-id
Router(config-router)#network network number
Router(config-router)#no auto-summary

2. Thay đổi băng thông và tự tổng hợp tuyến trong Interface.

Mã nguồn [Chọn]
Router(config-if)#bandwidth kilobits
Router(config-if)#ip summary-address protocol AS network number subnets mask

3. Cân bằng tải trong EIGRP.

Mã nguồn [Chọn]
Router(config-router)#variance number
4. Quảng bá Default Route.

Cách 1:

Mã nguồn [Chọn]
Router(config)#ip route 0.0.0.0 0.0.0.0 [interface/nexthop]
Router(config)#redistribute static

Cách 2:
Mã nguồn [Chọn]
Router(config)#ip default-network network number
Cách 3:
Mã nguồn [Chọn]
Router(config-if)#ip summary-network eigrp AS number 0.0.0.0 0.0.0.0
5. Quảng bá các tuyến khác trong EIGRP (không phải là Default).

Mã nguồn [Chọn]
Router(config-router)#redistribute protocol process ID metrics k1 k2 k3 k4 k5
Ex: Router(config-router)#redistribute ospf metrics 100 100 100 100 100

6. Chia sẻ Traffic trong EIGRP.

Mã nguồn [Chọn]
Router(config-router)#traffic share {balanced/min}
7. Các lệnh kiểm tra cấu hình EIGRP.

Mã nguồn [Chọn]
show ip eigrp neighbor
show ip eigrp interface
show ip eigrp topology
show ip eigrp traffic
debug eigrp packet

III. Switching - Chuyển mạch.

1. Cấu hình cơ bản chung cho một Switch.


Reset tất cả cấu hình của Switch và reload lại.

Mã nguồn [Chọn]
Switch#delete flash:vlan.dat
Switch#erase startup-config
Switch#reload

2. Cấu hình về Security và Management.

Mã nguồn [Chọn]
Switch(config)#hostname tên switch
Switch(config)#line console 0
Switch(config-line)#password mật khẩu
Switch(config-line)#login

Mã nguồn [Chọn]
Switch(config)#line vty 0 4
Switch(config-line)#pass mật khẩu
Switch(config-line)#login

3. Thiết lập địa chỉ IP và Default Gateway cho Switch.

Mã nguồn [Chọn]
Switch(config)#interface vlan1
Switch(config-int)#ip address địa chỉ subnetmask
Switch(config)#ip default-gateway địa chỉ
4. Thiết lập tốc độ và Duplex của cổng.

Mã nguồn [Chọn]
Switch(config-int)#speed tốc độ
Switch(config-int)#duplex full
5. Thiết lập dịch vụ HTTP và cổng.

Mã nguồn [Chọn]
Switch(config)#ip http server
Switch(config)#ip http port 80

6. Thiết lập và quản lý địa chỉ MAC.

Mã nguồn [Chọn]
Switch(config)#mac-address-table static địa chỉ MAC interface fastethernet số vlan
Switch#show mac-address-table
Switch#clear mac-address-table

7. Cấu hình bảo mật cho cổng.

Mã nguồn [Chọn]
Switch(config-if)#switchport mode acess
Switch(config-if)#switchport port-security
Cấu hình Static:

Mã nguồn [Chọn]
Switch(config-if)#switchport port-security mac-address địa chỉ MacCấu hình Sticky:

Mã nguồn [Chọn]
Switch(config-if)#switchport port-security mac-address sticky (thông dụng nhất)
Mã nguồn [Chọn]
Switch(config-if)#switchport port-security maximum value
Switch(config-if)#switchport port-security violation shutdown

8. Tạo VLAN.

Cách 1:

Mã nguồn [Chọn]
Switch#vlan database
Switch(vlan)#vlan number

Cách 2: Khi gán các cổng vào VLAN dù VLAN chưa tồn tại nhưng Switch vẫn tự tạo.

Mã nguồn [Chọn]
Switch(config)#interface fastethernet 0/0
Switch(config-int)#switchport access vlan vlan-id

Muốn xoá VLAN ta làm như sau.

Mã nguồn [Chọn]
Switch(config-if)#no switchport access vlan vlan-id
Switch#clear vlan vlan_number (xoá toàn bộ vlan)

9. Gán nhiều cổng vào trong VLAN cùng một lúc và cấu hình Range.

Đối với dãy cổng không liên tục:
Mã nguồn [Chọn]
Switch(config)#interface range cổng 1 , cổng 2 , cổng 3
Đối với một dãy liên tục:
Mã nguồn [Chọn]
Switch(config)#interface range cổng 1-n
Switch(config-range)#switchport access vlan vlan-id

Ví dụ:
Mã nguồn [Chọn]
Switch(config)#interface range f0/0 , f0/2 , f0/4
Switch(config)#interface range f0/0-10
Switch(config-range)#switchport access vlan 10

10. Cấu hình cổng Trunk.

Mã nguồn [Chọn]
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchpor trunk encapsulation encapsulation-type
Switch#show int trunk

11. Cấu hình VTP.

Mã nguồn [Chọn]
Switch#vlan database
Switch(vlan)#vtp mode {server/client/transperant}
Switch(vlan)#vtp domain domain-name ( cùng domain thì mới giao tiếp được)
Switch(vlan)#vtp password password-number (Tạo pass cho domain- cùng pass thì mới giao tiếp đựơc)
Switch(vlan)#vtp pruning------>chỉ sd cho mode server
Switch#show vtp status
Switch#show cdp nei
Switch#show vlan brief

12. Cấu hình Inter-VLAN trên Router.

Mã nguồn [Chọn]
Router(config)#interface fastethernet 0/0.1
Router(config-subif)#encapsulation type
Router(config-subif)#ip address địa-chỉ subnetmask

IV. Access-List và các cấu hình liên quan.

1. Nhắc lại về lý thuyết.

Có 2 loại access-list:Loại thứ nhất: Standard IP Access-List chỉ lọc dữ liệu dựa vào địa chỉ IP nguồn. Range của loại này là từ 1->99. Nên được áp dụng với cổng gần đích nhất.

Loại thứ hai: Extended IP Access-List lọc dữ liệu dựa vào:
  • Địa chỉ IP nguồn.
  • Địa chỉ IP đích.
  • Giao thức (TCP, UDP).
  • Số cổng (HTTP, Telnet...).
  • Và các thông số khác như Windcard mask.
  • Range của loại này là từ 100 ->199. Nên được áp dụng với cổng gần nguồn nhất.
Hai bước để cấu hình Access-List:
Bước 1: Tạo Access-List trong chế độ cấu hình Config.
Bước 2: Áp dụng Access-List cho từng cổng tuỳ theo yêu cầu ở chế độ cấu hình (config-if).

Chú ý:
  • Mặc định của tất cả Access-list là deny all, vì vậy trong tất cả các access-list tối thiểu phải có 1 lệnh permit. Nếu trong access-list có cả permit và deny thì nên để các dòng lệnh permit bên trên.
  • Về hướng của access-list (In/Out) khi áp dụng vào cổng có thể hiểu đơn giản là: In là từ host, Out là tới host hay In vào trong Router, còn Out là ra khỏi Router.
  • Đối với IN router kiểm tra gói tin trước khi nó được đưa tới bảng xử lý. Đối vơi OUT, router kiểm tra gói tin sau khi nó vào bảng xử lý.
  • Windcard mask được tính bằng công thức:
  • WM = 255.255.255.255 – Subnet mask (Áp dụng cho cả Classful và Classless addreess)
  • 0.0.0.0 255.255.255.255 = any.
  • Ip address 0.0.0.0 = host ip address (chỉ định từng host một)
2. Cấu hình Standard Access-List

Mã nguồn [Chọn]
Router(config)#access-list 1 deny 172.16.0.0 0.0.255.255
Router(config)#access-list 1 permit any
Router(config)#interface fastethernet 0/0
Router(config-in)#ip access-group in

3. Cấu hình Extended Access-List.

Mã nguồn [Chọn]
Router(config)#access-list 101 deny tcp 172.16.0.0 0.0.255.255 host 192.168.1.1 eq telnet
Router(config)#access-list 101 deny tcp 172.16.0.0 0.0.255.255 host 192.168.1.2 eq ftp
Router(config)#access-list 101 permit any any
Router(config)#interface fastethernet 0/0
Router(config-int)#ip access-group out

4. Cấu hình named ACL thay cho các số hiệu.

Mã nguồn [Chọn]
Router(config)#ip access-list extended server-access (tên của access-list)
Router(config-ext-nacl)#permit tcp any host 192.168.1.3 eq telnet
Router(config)#interface fastethernet 0/0
Router(config-int)#ip access-group server-access out

5. Permit hoặc Deny Telnet sử dụng Standard ACL.

Mã nguồn [Chọn]
Router(config)#access-list 2 permit 172.16.0.0 0.0.255.255
Router(config)#access-list 2 deny any
Router(config)#line vty 0 4
Router(config-line)#password cisco
Router(config-line)#login
Router(config-line)#ip access-class 2 in

6. Xoá và kiểm tra Access-List.

Muốn xoá thì ta dùng lệnh sau:
Mã nguồn [Chọn]
Router(config)# no ip access-list id
Kiểm tra ACLta dùng các lệnh sau:

Mã nguồn [Chọn]
show access-list
show running-config
show ip interface

V. NAT – PPP – Frame Relay.

1. Cấu hình NAT

Cấu hình Static NAT.

Mã nguồn [Chọn]
Router(config)#ip nat inside source static [inside local address] [inside global address]Ví dụ:
Mã nguồn [Chọn]
R(config)#ip nat inside source statice 10.0.0.1 202.103.2.1 (Địa chỉ 10.10.0.1 sẽ được chuyển thành 202.103.2.1 khi đi ra khỏi Router)
Sau khi cấu hình xong phải áp dụng vào cổng in và cổng out, trong ví dụ dưới đây, cổng Ethernet là công in, còn cổng Serial là cổng out.

Mã nguồn [Chọn]
Router(config)#interface ethernet 0
Router(config-if)#ip nat inside

Mã nguồn [Chọn]
Router(config)#interface serial 0
Router(config-if)#ip nat outside

Cấu hình Dynamic NAT

Mã nguồn [Chọn]
Router(config)#ip nat pool [ tên pool] [A.B.C.D A1.B1.C1.D1] netmask [mặt nạ]
Router(config)#ip nat inside source list [số hiệu ACL] pool [tên pool]
Router(config)#access-list [số hiệu ACL] permit A.B.C.D windcard masks

Ví dụ:
Mã nguồn [Chọn]
R(config)#ip nat pool nat-pool1 179.9.8.80 179.9.8.95 netmask 255.255.255.0
R(config)#ip nat inside source list 1 pool nat-pool1
R(config)#access-list 1 permit 10.1.0.0 0.0.0.255

Sau đó áp vào cổng In và Out như Static NAT.

Chú ý: Giải địa chỉ inside local address và inside global address phải nằm trong giải cho phép của ACL.

Cấu hình NAT OverloadCấu hình overload với 1 địa chỉ IP cụ thể:

Mã nguồn [Chọn]
Router(config)#ip nat pool [tên pool] [ip global inside] [subnet mask]
Router(config)#ip nat inside source list [tên số hiệu ACL] pool [tên pool] overload
Router(config)#access-list [số hiệu] permit [địa chỉ] [windcard mask]

Ví dụ:
Mã nguồn [Chọn]
R(config)#access-list 2 permit 10.0.0.0 0.0.0.255
R(config)#ip nat pool nat-pool2 179.9.8.20 255.255.255.240
R(config)#ip nat inside source list 2 nat-pool2 overload

Cấu hình overload dùng địa chỉ của cổng ra. Thường xuyên được dung hơn là trường hợp trên.

Mã nguồn [Chọn]
Router(config)#ip nat inside source list [tên số hiệu ACL] interface [cổng ra] overload
Router(config)#access-list [số hiệu] permit [địa chỉ] [windcard mask]

Ví dụ:
Mã nguồn [Chọn]
R(config)#ip nat inside source list 3 interface serial 0 overload
R(config)#access-list 3 permit 10.0.0.0 0.0.0.255

Các lệnh Clear NAT/PAT

Lệnh xóa tất cả dynamic nat trên toàn bộ các Interface.

Mã nguồn [Chọn]
Router#clear ip nat translation *Lệnh xóa các single nat trên từng Interface

Mã nguồn [Chọn]
Router#clear ip nat translation [inside/outside] [global ip - local ip]Lệnh xóa các extended nat trên từng Interface

Mã nguồn [Chọn]
Router#clear ip nat translation protocol [inside/outside] [global ip - global port – local ip – local port]Kiểm tra và Debug các NAT và PAT

Mã nguồn [Chọn]
Router#show ip nat translation
Router#show ip nat statics
Router#debug ip nat

Cấu hình DHCP

Mã nguồn [Chọn]
Router(config)#ip dhcp excluded-address ip-address (end-ip-address)
Router(config)#ip dhcp pool [tên pool]
Router(dhcp-config)#network addess subnetmask
Router(dhcp-config)#default-router address
Router(dhcp-config)#dns-server address
Router(dhcp-config)#netbios-name-server address
Router(dhcp-config)#domain-name tên domain
Router(dhcp-config)#lease ngày/giờ/phút

Kiểm tra và Troubleshoot cấu hình DHCP

Mã nguồn [Chọn]
Router#show ip dhcp binding
Router#debug ip dhcp server events

Trong trường hợp DHCP server không nằm cùng mạng với host.

Chú ý: khi DHCP server không cùng mạng với host thì ta phải dùng lệnh ip helper-address giúp host đến DHCP server.

Mã nguồn [Chọn]
Router(config)#interface [cổng nằm cùng mạng với host]
Router(config-if)#ip helper-address [địa chỉ của DHCP server]

Chú ý: Trong trường hợp muốn gói tin của host được broadcast ở mạng chứa DHCP thì ta dùng thêm lệnh ip directed-broadcast ở cổng cùng mạng với DHCP Server.

Mã nguồn [Chọn]
Router(config)#interface [cổng nằm cùng mạng với dhcp]
Router(config-ì)#ip directed-broadcast

2. Cấu hình PPP.

Cấu hình cơ bản.

Mã nguồn [Chọn]
R(config)#interface serial 0/0
R(config-if)#encapsulation ppp

Cấu hình PAP.

Cấu hình PAP không yêu cầu hai Router giống nhau về password nhưng CHAP thì phải có.

Cấu hình trên RB.
Mã nguồn [Chọn]
R(config)#host RA
RA(config)#username RB password 321
RA(config-if)#encapsulation ppp
RA(config-if)#ppp authentication pap
RA(config-if)#ppp pap sent-username RA password 123

Cấu hình trên RB.
Mã nguồn [Chọn]
R(config)#host RB
RB(config)#username RA password 123
RB(config-if)#encapsulation ppp
RB(config-if)#ppp authentication pap
RB(config-if)#ppp pap sent-username RB password 321

3. Cấu hình CHAP. Yêu cầu phải giống nhau về Password.

Cấu hình trên RA.
Mã nguồn [Chọn]
R(config)#host RA
RA(config)#username RB password 123
RA(config-if)encapsulation ppp
RA(config-if)ppp authentication chap

Cấu hình trên RB.

Mã nguồn [Chọn]
R(config)#host RB
RB(config)#username RA password 123
RB(config-if)encapsulation ppp
RB(config-if)ppp authentication chap

Các cấu hình khác của PPP.

Cấu hình Multilink

Mã nguồn [Chọn]
R(config-if)#encapsulation ppp
R(config-if)#ppp multilink

Cấu hình Compression
Mã nguồn [Chọn]
R(config-if)#encapsulation ppp
R(config-if)#compress [predictor/stac/mppc]

Cấu hình Error detection

Mã nguồn [Chọn]
R(config-if)#encapsulation ppp
R(config-if)#ppp quality [phần trăm]

5. Các lệnh kiểm tra cấu hình PPP.

Mã nguồn [Chọn]
R#show interface (xem encapsulation)
R#debug ppp negotiation (Xem quá trình kết nối giữa 2 node)
R#debug ppp authentication (Xem quá trình xác thực giữa 2 node)
3. Cấu hình Frame-Relay.

Cấu hình đơn giản

Mã nguồn [Chọn]
R(config-if)#encapsulation frame-relay {ciso| ietf} (mặc định là cisco)
Khi lệnh này được thực thi, DLCI sẽ được Inverse ARP tự động map, người dùng không cần phải làm gì cả.
Nhưng Inverse ARP không làm việc với các kết nối Hub-and-Spoke

Cấu hình Frame-relay static map.

Mã nguồn [Chọn]
R(config-if)#encapsulation frame-relay
R(config-if)#frame-relay map ip remote–ip-address local-dlci [broadcast] [cisco| ietf]
IP address trong dòng lệnh trên chỉ lấy làm minh họa bởi nó rất phổ biến, chính xác phải là remote–protocol–address.
Broadcast trong câu lệnh trên có 2 chức năng:
  • Forward broadcast khi multicast không được khởi động.
  • Đơn giản hóa cấu hình OSPF cho mạng nonbroadcast sử dụng FRelay.
Ví dụ:

Mã nguồn [Chọn]
R(config-if)#encapsulation frame-relay
R(config-if)#frame-relay map ip 192.168.2.1 100 broadcast

Cấu hình FR trong mạng None Broadcast MutiAccess
Trong mạng Broadcast khi 1 máy tính truyền frame tất cả các node lắng nghe frame nhưng chỉ có node cần nhận mới nhận được.
Trong mạng None Broadcast khi 1 máy tính truyền frame thì chỉ có node cần nhận mới lắng nghe và nhận được frame đó, các node còn lại thì không. Frame được truyền qua 1 virtual Circuit hoặc 1 thiết bị chuyển mạch.
Star topology có thể được coi như là 1 mạng Hub and Spoke.
Giải quyết vấn đề với Routing Updates mà không disable Split Horizal

Giải pháp dùng Sub-interface.

Mã nguồn [Chọn]
R(config)#interface s0/0
R(config-if)#encapsulation frame-relay
R(config-if)interface s0/0.1 [multipoint| point-to-point]

point-to-point: Mỗi subinterface có subnet riêng của mình. Broadcast và Split horizol không là vấn đề.
Multi-point: Tất cả các subinterface liên quan phải cùng chung 1 subnet và như vậy Broadcast và Split horizol sẽ có vấn đề.

Ví dụ:
(Point-to-point)
Mã nguồn [Chọn]
R(config)#interface s0/0
R(config-if)#encapsulation frame-relay
R(config-if)#interface s0/0.1 point-to-point
R(config-subif)#frame-relay interface-dlci 18

(Multipoint)
Mã nguồn [Chọn]
R(config)#interface s0/0
R(config-if)#encapsulation frame-relay
R(config-if)#interface s0/0.2 multipoint
R(config-subif)#frame-relay interface-dlci 19
R(config-subif)#frame-relay interface-dlci 20

Cấu hình trên Frame-relay Switching

Mã nguồn [Chọn]
R(config)#frame-relay switching
R(config)#interface s0/0
R(config-if)#encapsulation frame-relay
R(config-if)#frame-relay intf-type dce
R(config-if)#frame-relay route 103interface serial 0/1 301