Tác giả Chủ đề: Định tuyến và cấu hình của chúng Router và Configuration  (Đã xem 287 lần)

0 Thành viên và 1 Khách đang xem chủ đề.

Ngủ rồi CCNACCNP

  • Hero Member
  • *****
  • Bài viết: 3980
  • Số Lần: +73/-0
Định tuyến và cấu hình của chúng Router và Configuration
« vào: Tháng Tư 20, 2019, 06:57:43 PM »
1. Định tuyến và cấu hình của chúng

Định tuyến IP là quá trình di chuyển các gói từ mạng này sang mạng khác bằng bộ định tuyến. Khi tất cả các bộ định tuyến biết về tất cả các mạng, một giao thức được định tuyến có thể được sử dụng để gửi dữ liệu người dùng (gói) thông qua doanh nghiệp được thiết lập. Các giao thức được định tuyến được gán cho một Interface và xác định phương thức phân phối gói. Ví dụ về các giao thức được định tuyến là IP và IPv6. Nếu thay đổi xảy ra trong mạng, các giao thức định tuyến động sẽ tự động thông báo cho tất cả các bộ định tuyến về sự kiện. Nếu định tuyến tĩnh được sử dụng, quản trị viên chịu trách nhiệm cập nhật tất cả các thay đổi bằng tay lên tất cả các bộ định tuyến. Thông thường, trong một mạng lớn, sự kết hợp của cả định tuyến động và định tuyến tĩnh được sử dụng.


Ví dụ:


Trong ví dụ 1 ở trên, điều gì xảy ra khi host A gửi dữ liệu đến Máy chủ HTTP.


    Địa chỉ đích của khung, từ host A, sẽ là địa chỉ MAC của giao diện Fa0 / 0 của Bộ định tuyến A.
    Địa chỉ đích của gói sẽ là địa chỉ IP của card mạng Interface (NIC) của máy chủ HTTP.
    Số cổng đích trong tiêu đề phân đoạn sẽ có giá trị là 80.

Trong ví dụ 2 ở trên, Host 4 giao tiếp với máy chủ Sales như thế nào?


    Để bắt đầu liên lạc với máy chủ Bán hàng, Máy chủ 4 gửi yêu cầu ARP. Các thiết bị được trưng bày trong cấu trúc liên kết sẽ đáp ứng yêu cầu này như thế nào?
    Máy chủ 4 đã nhận được trả lời ARP. Máy chủ 4 bây giờ sẽ xây dựng một gói, sau đó đặt gói này vào khung. Thông tin nào sẽ được đặt trong tiêu đề của gói rời khỏi Máy chủ 4 nếu Máy chủ 4 sẽ liên lạc với máy chủ Bán hàng?
    Cuối cùng, bộ định tuyến Lab A đã nhận được gói và sẽ gửi nó ra Fa0 / 0 trên mạng LAN về phía máy chủ. Khung sẽ có gì trong tiêu đề là địa chỉ nguồn và đích?
    Máy chủ 4 đang hiển thị hai tài liệu web từ máy chủ Bán hàng trong hai cửa sổ trình duyệt cùng một lúc. Làm thế nào dữ liệu tìm được đường đến đúng cửa sổ trình duyệt.

2. Cấu hình định tuyến IP Routing


- Hộp thoại cấu hình hệ thống -

Bạn có muốn nhập hộp thoại cấu hình ban đầu? [có / không]: n

Nhấn Quay Lại để bắt đầu lại!

Trích dẫn
Router>en

Router#config t

Nhập các lệnh cấu hình, mỗi lệnh một dòng. Kết thúc với CNTL / Z.

Trích dẫn
Router(config)#hostname Corp

Corp(config)#enable secret net

Corp(config)#interface vlan 1

Corp(config-if)#description Switch Card to Core Network

Corp(config-if)#ip address 10.1.1.1 255.255.255.0

Corp(config-if)#no shutdown

Corp(config-if)#int f1/0

Corp(config-if)#description Switch Port connection to WWW Server

Corp(config-if)#no shutdown

Corp(config-if)#int f1/1

Corp(config-if)#description Switch port connection to Email Server

Corp(config-if)#no shut

Corp(config-if)#int f1/2

Corp(config-if)#description Switch port connection to DNS Server

Corp(config-if)#no shut

Corp(config-if)#int s0/0/0

Corp(config-if)#description 1st Connection to R1

Corp(config-if)#ip address 10.1.2.1 255.255.255.0

Corp(config-if)#no shut

Corp(config-if)#int s0/0/1

Corp(config-if)#description 2nd Connection to R1

Corp(config-if)#ip address 10.1.3.1 255.255.255.0

Corp(config-if)#no shut

Corp(config-if)#int s0/1/0

Corp(config-if)#description Connection to R2

Corp(config-if)#ip address 10.1.4.1 255.255.255.0

Corp(config-if)#no shut

Corp(config-if)#int fa0/0

Corp(config-if)# description Connection to R3

Corp(config-if)# ip address 10.1.5.1 255.255.255.0

Corp(config-if)#no shut

Corp(config-if)#line con 0

Corp(config-line)#password console

Corp(config-line)#login

Corp(config-line)#logging synchronous

Corp(config-line)#exec-timeout 0 0

Corp(config-line)#line aux 0

Corp(config-line)#password aux

Corp(config-line)#login

Corp(config-line)#exit

Corp(config)#line vty 0 ?

<1-15> Last Line number

<cr>

Corp(config)#line vty 0 15

Corp(config-line)#password telnet

Corp(config-line)#login

Corp(config-line)#exit

Corp(config)#no ip domain lookup

Corp(config)#banner motd # This is my Corp 2811 ISR Router #

Corp(config-if)#^Z

Corp#copy running-config startup-config

Destination filename [startup-config]?[enter]

Building configuration…

[OK]

Corp#

R1#erase start

% Incomplete command.

R1#erase startup-config

Erasing the nvram filesystem will remove all configuration files!

Continue? [confirm][enter]

[OK]

Erase of nvram: complete

R1#reload

Proceed with reload? [confirm][enter]

(output cut)

%Error opening tftp://255.255.255.255/network-confg (Timed out)

%Error opening tftp://255.255.255.255/cisconet.cfg (Timed out)

- Hộp thoại cấu hình hệ thống -


Bạn có muốn nhập hộp thoại cấu hình ban đầu? [có / không]: n

Tôi muốn chỉ ra rằng đầu ra cho chúng ta biết bộ định tuyến đang tìm kiếm một host TFTP để xem liệu nó có thể tải xuống một cấu hình hay không. Khi thất bại, nó đi thẳng vào chế độ thiết lập.

Nhấn Quay Lại để bắt đầu lại

Trích dẫn
Router>en

Router#config t

Router(config)#hostname R1

R1(config)#enable secret net

R1(config)#int s0/0/0

R1(config-if)#ip address 10.1.2.2 255.255.255.0

R1(config-if)#Description 1st Connection to Corp Router

R1(config-if)#no shut

R1(config-if)#int s0/0/1

R1(config-if)#ip address 10.1.3.2 255.255.255.0

R1(config-if)#no shut

R1(config-if)#description 2nd connection to Corp Router

R1(config-if)#int f0/0

R1(config-if)#ip address 192.168.10.1 255.255.255.0

R1(config-if)#description Connection to Finance PC

R1(config-if)#no shut

R1(config-if)#int f0/1

R1(config-if)#ip address 192.168.20.1 255.255.255.0

R1(config-if)#description Connection to Marketing PC

R1(config-if)#no shut

R1(config-if)#line con 0

R1(config-line)#password console

R1(config-line)#login

R1(config-line)#logging synchronous

R1(config-line)#exec-timeout 0 0

R1(config-line)#line aux 0

R1(config-line)#password aux

R1(config-line)#login

R1(config-line)#exit

R1(config)#line vty 0 ?

<1-807> Last Line number

<cr>

R1(config)#line vty 0 807

R1(config-line)#password telnet

R1(config-line)#login

R1(config-line)#banner motd # This is my R1 Router #

R1(config)#no ip domain-lookup

R1(config)#exit

R1#copy run start

Destination filename [startup-config]?[enter]

Building configuration…

[OK]

R1#show ip route

10.0.0.0/24 is subnetted, 4 subnets

    1.3.0 is directly connected, Serial0/0/1
    1.2.0 is directly connected, Serial0/0/0
    168.20.0 is directly connected, FastEthernet0/1
    168.10.0 is directly connected, FastEthernet0/0

R1#10.1.2.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:

!!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

R1#

Corp#sh ip route

10.0.0.0/24 is subnetted, 4 subnets

10.1.3.0 is directly connected, Serial0/0/1

10.1.2.0 is directly connected, Serial0/0/0

192.168.20.0 is directly connected, FastEthernet0/1

192.168.10.0 is directly connected, FastEthernet0/0

R1#10.1.2.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:

!!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

R1#

Corp#sh ip route

(output cut)

10.0.0.0/24 is subnetted, 4 subnets

10.1.3.0 is directly connected, Serial0/0/1

10.1.2.0 is directly connected, Serial0/0/0

10.1.1.0 is directly connected, Vlan1

Remember that you don’t need to use the clock rate command in production. ISR routers will auto-detect a DCE-type cable and automatically configure the clock rate 2000000.

Router>en

Router#config t

Router(config)#hostname R2

R2(config)#enable secret net

R2(config)#int s0/0/0

R2(config-if)#ip address 10.1.4.2 255.255.255.0

R2(config-if)#description Connection to Corp Router

R2(config-if)#no shut

R2(config-if)#int f0/0

R2(config-if)#ip address 192.168.30.1 255.255.255.0

R2(config-if)#description Connection to Sales PC

R2(config-if)#no shut

R2(config-if)#int f0/1

R2(config-if)#ip address 192.168.40.1 255.255.255.0

R2(config-if)#description Connection to HR PC

R2(config-if)#no shut

R2(config-if)#line con 0

R2(config-line)#password console

R2(config-line)#login

R2(config-line)#logging sync

R2(config-line)#exec-timeout 0 0

R2(config-line)#line aux 0

R2(config-line)#password aux

R2(config-line)#login

R2(config-line)#exit

R2(config)#line vty 0 807

R2(config-line)#password telnet

R2(config-line)#login

R2(config-line)#exit

R2(config)#banner motd # This is my R2 Router #

R2(config)#no ip domain-lookup

R2(config)#^Z

R2#copy run start

Destination filename [startup-config]?[enter]

Building configuration…

[OK]

R2#sh ip route

10.0.0.0/24 is subnetted, 3 subnets

192.168.30.0 is directly connected, FastEthernet0/0

192.168.40.0 is directly connected, FastEthernet0/1

10.1.4.0 is directly connected, Serial0/0/0

Router>en

Router#config t

Router(config)#hostname R3

R3(config)#enable secret net

R3(config)#int f0/0

R3(config-if)#ip address 10.1.5.2 255.255.255.0

R3(config-if)#description Connection to Corp Router

R3(config-if)#no shut

R3(config-if)#int dot11radio0/0/0

R3(config-if)#ip address 172.16.10.1 255.255.255.0

R3(config-if)#description WLAN for Mobile User

R3(config-if)#no shut

R3(config-if)#ssid ADMIN

R3(config-if-ssid)#guest-mode

R3(config-if-ssid)#authentication open

R3(config-if-ssid)#infrastructure-ssid

R3(config-if-ssid)#exit

R3(config-line)#line con 0

R3(config-line)#password console

R3(config-line)#login

R3(config-line)#logging sync

R3(config-line)#exec-timeout 0 0

R3(config-line)#line aux 0

R3(config-line)#password aux

R3(config-line)#login

R3(config-line)#exit

R3(config)#line vty 0 807

R3(config-line)#password telnet

R3(config-line)#login

R3(config-line)#exit

R3(config)#banner motd # This is my R3 Router #

R3(config)#no ip domain-lookup

R3(config)#^Z

R3#copy run start

Destination filename [startup-config]?[enter]

Building configuration…

[OK]

R3(config-if)#int dot11radio0/0/0

R3(config-if)#ip address 172.16.10.1 255.255.255.0

R3(config-if)# description WLAN for Mobile User

R3(config-if)#no shut

R3(config-if)#ssid ADMIN

R3(config-if-ssid)#guest-mode

R3(config-if-ssid)#authentication open

R3(config-if-ssid)#infrastructure-ssid

3. Cấu hình DHCP server trên Bộ định tuyến của chúng tôi


Để tạo máy chủ DHCP trên bộ định tuyến, bạn chỉ cần tạo tên nhóm, thêm mạng / mạng con và cổng mặc định và loại trừ mọi địa chỉ bạn không muốn đưa ra (như địa chỉ cổng mặc định) và bạn thường thêm một máy chủ DNS là tốt.

Trích dẫn
R3#config t

R3(config)#ip dhcp pool Admin

R3(dhcp-config)#network 172.16.10.0 255.255.255.0

R3(dhcp-config)#default-router 172.16.10.1

R3(dhcp-config)#ip name-server 172.16.10.4

R3(dhcp-config)#exit

R3(config)#ip dhcp excluded-address 172.16.10.1 172.16.10.10

R3(config)#

R3#sh ip dhcp binding

IP address        Client-ID/Hardware address

172.16.10.11    0001.96AB.8538

PC>ipconfig /all

4. Định cấu hình định tuyến IP trong mạng của chúng tôi

Định tuyến tĩnh - Định tuyến tĩnh có các lợi ích sau:


    Không có chi phí hoạt động trên CPU bộ định tuyến, điều đó có nghĩa là bạn có thể mua bộ định tuyến rẻ hơn mức bạn sẽ sử dụng nếu bạn đang sử dụng định tuyến động.
    Không có việc sử dụng băng thông giữa các bộ định tuyến, điều đó có nghĩa là bạn có thể tiết kiệm tiền cho các liên kết WAN.
    Nó bổ sung bảo mật vì quản trị viên có thể chọn chỉ cho phép truy cập định tuyến vào một số mạng nhất định.

Định tuyến tĩnh có những nhược điểm sau:

    Quản trị viên phải thực sự hiểu mạng nội bộ và cách mỗi bộ định tuyến được kết nối để định cấu hình các tuyến chính xác.
    Nếu một mạng được thêm vào mạng nội bộ, quản trị viên phải thêm một tuyến đến mạng đó trên tất cả các bộ định tuyến bằng tay.
    Nó không khả thi trong các mạng lớn bởi vì duy trì nó sẽ là một công việc toàn thời gian.

AS (hệ thống tự trị) số - ISP phải đăng ký chính thức NHƯ. bởi IANA (internet được giao không có thẩm quyền). Nó là 16-bit không. (65536 số.) ASN 0 (xác định mạng không định tuyến) và ASN 65535 được bảo lưu. ASN 64496-64511 dành riêng để sử dụng trong tài liệu và mã mẫu. ASN 64512-65534 cho mục đích riêng tư.

Chi phí số liệu có nghĩa là nhanh hơn (đường dẫn ngắn nhất). Ví dụ. BGP sử dụng trọng số, tổng hợp ưu tiên cục bộ, độ dài đường dẫn AS, loại gốc cho chi phí.

Giao thức định tuyến Classfull và Classless -




Khoảng cách vector so với giao thức định tuyến trạng thái liên kết -



Giao thức định tuyến - RIP v1 & RIP v2. OSPF, IS-IS. Giao thức định tuyến của Cisco - IGRP, EIGRP, BGP.

Giao thức được định tuyến - IP, Novell IPx, DEC net, AppleTalk, Banyan Vines, hệ thống mạng Xerox.

RIP

     RIP sử dụng cổng UDP số. 520 để cập nhật tuyến đường.
     Số liệu là số hop. Tối đa hop 15. Hop 16 có nghĩa là không đạt được trên mạng.
     Nó là tiêu chuẩn mở nên được gọi là IP RIP.
     Cập nhật định kỳ 30s theo mặc định và gửi thông tin đầy đủ cho RIP hàng xóm.
     RIP mất một số thời gian để hội tụ, nhưng nó sử dụng ít CPU Power hơn.
     Đó là giao thức định tuyến vector khoảng cách.

Sự khác biệt giữa RIPv1 và RIPv2




RIP ng - Nó là phần mở rộng của RIP v2. Nó hỗ trợ IPv6. Nó sẽ gửi các bản cập nhật trên cổng UDP số 521. Nhóm Multicast là FF02 :: 9.

Trích dẫn
A(config)# router rip

A(config-router)# version 2

A# show ip protocols

Sending          Receiving

2                       2

2                       2

Hẹn giờ RIP -

     Cập nhật hẹn giờ (30 giây)
     Bộ hẹn giờ không hợp lệ (30 * 6 = 180s) - Bộ định tuyến B chờ trong 180 giây, nếu cập nhật từ bộ định tuyến A không đến thì Bộ định tuyến B coi là không hợp lệ hoặc không thể truy cập.
     Giữ đồng hồ bấm giờ (180 giây) - Nó được sử dụng để ngăn chặn các vòng lặp. Sau khi bộ đếm thời gian không hợp lệ, không có bộ định tuyến sẽ nhận được thông tin bộ định tuyến A.
     Bộ đếm thời gian xả (180 + 60 = 240s) - Sau 240 tất cả bộ định tuyến nói RIP sẽ xóa mục nhập của bộ định tuyến A.
     A # show ip giao thức Cập nhật định tuyến 30 giây Cập nhật không hợp lệ 180 giây Giữ cập nhật 180 giây.
     Cập nhật 240s.

Trích dẫn
A(config)# router rip

A(config-router)# timer basic 40 100 100 150

Ngăn chặn LOOP Routing -


     Route poisoning
    Split horizon
    Triggered update
    Poison reverse
    Hold down timer

EIGRP -

     Độc quyền của Cisco.
     Giao thức định tuyến lai.
     Số liệu - Theo mặc định BW, độ trễ, độ tin cậy tải

     Ở đây sử dụng công thức DUAL (thuật toán khuếch tán-cập nhật).
     Gói phân phối được xử lý bằng cách sử dụng - RTP (Giao thức truyền tải đáng tin cậy) và địa chỉ phát đa hướng đáng tin cậy 224.0.0.10
     Định tuyến không hỗ trợ và hỗ trợ VLSM.

Lợi thế -

     Đơn giản (lệnh như RIP)
     Giữ tuyến dự phòng (nhưng OSPF don Patrick giữ tuyến dự phòng)
     Hội tụ nhanh.
     Tóm tắt tuyến đường (Trong tóm tắt OSPF xảy ra trên bộ định tuyến ABR).
     Cân bằng tải - chi phí không đồng đều.
     Hỗ trợ nhiều giao thức định tuyến (IP, IPx, Novel, AppleTalk).

Tính toán Routing tốt nhất -

K1 – BW           K2 – Delay        K3 – Load       K4 – reliability

Metric = ((107/least BW in kbps) + Cumulative delay) *256

OSPF -

     Đây là giao thức định tuyến trạng thái liên kết.
     Nó là tiêu chuẩn mở nên rất phổ biến.
     Sử dụng giao thức IP 89.
     Thuật toán định tuyến trạng thái liên kết hoặc thuật toán Dijkstra.
     Hỗ trợ VLSM / không có lớp.
     Số liệu là chi phí (dựa trên BW).
     Cập nhật phát đa hướng trên 224.0.0.5 (tất cả bộ định tuyến SPF) và 224.0.0.6 (tất cả bộ định tuyến được chỉ định).

ID bộ định tuyến - Mã định danh duy nhất cho mỗi mạng. Nó giống như địa chỉ IP. Vì vậy, bộ định tuyến id mặc định = Địa chỉ IP tối đa của các giao diện bộ định tuyến.

LSA -

     Bộ định tuyến gửi LSA cho nhau.
     LSA được giữ trong bộ nhớ cơ sở dữ liệu trạng thái liên kết (LSDB).
     Đó là tên cấu trúc dữ liệu. Nó chứa thông tin cấu trúc liên kết.
     Trong LSA, ID bộ định tuyến, trình tự số. và tuổi (thứ hai).
     Các loại LSA - Bộ định tuyến LSA, LSA mạng, LSA tóm tắt khu vực, LSBR tóm tắt, LSA bên ngoài loại 1, LSA bên ngoài loại 2.

Chúc các bạn thành công.   Tom_and_Jerry 1.gif


Ngủ rồi CCIEInternetworkExpert

  • Sr. Member
  • ****
  • Bài viết: 444
  • Số Lần: +1/-0
Định tuyến và cấu hình của chúng Router và Configuration
« Trả lời #1 vào: Tháng Tư 20, 2019, 06:57:45 PM »
 Tom_and_Jerry 1.gif


 

Related Topics

  Tiêu đề / Tác giả Trả lời Bài mới
0 Trả lời
335 Lượt xem
Bài mới Tháng Tư 14, 2018, 02:11:38 PM
gửi bởi CCNACCNP
1 Trả lời
3692 Lượt xem
Bài mới Tháng Mười Hai 31, 2018, 02:13:03 PM
gửi bởi Admin
1 Trả lời
2228 Lượt xem
Bài mới Tháng Mười Hai 31, 2018, 02:15:18 PM
gửi bởi Admin
1 Trả lời
425 Lượt xem
Bài mới Tháng Mười Hai 31, 2018, 02:21:59 PM
gửi bởi Admin
1 Trả lời
21 Lượt xem
Bài mới Tháng Tư 22, 2019, 03:25:22 PM
gửi bởi CCIEInternetworkExpert